TILING CORRIDOR

 TILING CORRIDOR


You have an infinite supply of 2 x 1 dimension tiles.
You are allowed to rotate the tile to orient them horizontally or vertically.




You want to tile a 2 x N dimension corridor using 2 x 1 tile.
Find the number of unique ways of tiling the 2 x N dimension corridor modulo 1000000007.




1≤N≤10^5


INPUT

Single integer N denoting the length of the corridor.
OUTPUT

Output a single integer - number of ways of tiling the 2 x N dimension corridor using 2 x 1 tiles modulo 10^9+7

EXAMPLE

Sample 1 INPUTtext
3

Sample 1 OUTPUTtext
3

#include <bits/stdc++.h>

using namespace std;

#define int            long long int
#define F              first
#define S              second
#define pb             push_back
#define si             set <int>
#define vi             vector <int>
#define pii            pair <int, int>
#define vpi            vector <pii>
#define vpp            vector <pair<int, pii>>
#define mii            map <int, int>
#define mpi            map <pii, int>
#define spi            set <pii>
#define endl           "\n"
#define sz(x)          ((int) x.size())
#define all(p)         p.begin(), p.end()
#define double         long double
#define que_max        priority_queue <int>
#define que_min        priority_queue <int, vi, greater<int>>
#define bug(...)       __f (#__VA_ARGS__, __VA_ARGS__)
#define print(a)       for(auto x : a) cout << x << " "; cout << endl
#define print1(a)      for(auto x : a) cout << x.F << " " << x.S << endl
#define print2(a,x,y)  for(int i = x; i < y; i++) cout<< a[i]<< " "; cout << endl

inline int power(int a, int b)
{
  int x = 1;
  while (b)
  {
    if (b & 1) x *= a;
    a *= a;
    b >>= 1;
  }
  return x;
}

template <typename Arg1>
void __f (const char* name, Arg1&& arg1) { cout << name << " : " << arg1 << endl; }
template <typename Arg1, typename... Args>
void __f (const char* names, Arg1&& arg1, Args&&... args)
{
  const char* comma = strchr (names + 1, ',');
  cout.write (names, comma - names) << " : " << arg1 << " | "; __f (comma + 1, args...);
}

const int N = 1000000007 ;

void solve() {
int n;
cin>>n;
if(n<3){
    cout<<n<<endl;
    return;
}
int ans=0;
int one=2,two=1;
for (int i = 3; i <=n; i++)
{
    ans=(one+two)%N;
    two=one;
    one=ans;
}
cout<<ans<<endl;
}

int32_t main()
{
  ios_base::sync_with_stdio(0); cin.tie(0); cout.tie(0);


  clock_t z = clock();

  int t = 1;
//   cin >> t; 
  while (t--) solve();



  return 0;
}

Post a Comment

0 Comments